¡La seguridad es nuestro sector!

Con el fin de ofrecerle la transacción financiera más segura, nuestra aplicación de pago requiere que actualice su navegador a una de estas opciones:

Si el sistema operativo es anterior a OS X 10.8, la última versión de Safari no será compatible. Recomendamos utilizar la versión más reciente de Chrome o Firefox para completar esta transacción. La elección del navegador no afectará al rendimiento del software de Intego que ha adquirido.